You are here

How do I use the render farm to render a Maya project?

Preparing a File for Rendering

  1. Ensure your file has been properly set.  If not, set the project folder up. Open the Maya file that will be rendered. Ensure there are no errors that prevent the file from loading properly.
  2. Use Save As to create a new version of that file that will be used exclusively for rendering on the Render Farm. Save this file as a Maya Ascii.

  1. In this file, change all referenced items to imports through the following method:
  •  Open the Reference Editor by clicking on File -> Reference Editor.
  •  Select the first item on the list of references.
  •  In the Reference Editor window, select File -> Import Object From Reference.

  •  If a window appears asking about Namespaces, select Delete Namespaces.
  •  Repeat for each item until the list is empty, close the reference editor, and save the file.
  •  Note: Importing references can speed up a render and lower ram usage significantly, but it may also cause shaders to break or create other errors. If such errors occur, and re-assigning shaders results in an "error parsing arguments" message, a file containing references may be used as a last resort.
  1. Make sure all textures are correctly linked to their corresponding shaders. To do this quickly while Maya is open, go to Window-> General Editors -> File Path Editor, and make sure all textures show up correctly.
  • If no textures appear, make sure your project is set. Go to File -> Set Project, and select the project folder. Re-open the Maya file.
  • If one or a few textures do not appear, correct the file path for those textures in the attribute editor.
    • To correct file, select the folder icon next to Image Name.
    • Navigate to correct folder, select file, and select Open.

 

  • Save the file.
  1. If using fur, make sure that any length/direction/baldness maps are linked correctly by checking the file paths in the Attribute Editor.
  2. Play through the animation at real-time. Make sure there are no uncached simulations, and all caches are being found. All simulations must be cached or the file will not render correctly.
  • If no caches are found, make sure your project is set. Go to File -> Set Project, and select the project folder. Re-open the Maya file.
  • If one or a few caches are not found, correct the file path for those caches in the Attribute Editor.
    •  Select the simulation from Outliner Panel, navigate to the Cache tab in the Attribute Editor.

 
    •  Ensure the file path is correct in the Base Directory
    •   If it is not the correct file, select the folder next to the Base Name, navigate to correct file and select open.
  • Save the file.
  1. Open the Render Settings window and make sure all options are set correctly.
  • Make sure that naming conventions, file type, and frame padding are appropriately set.
  • Set the camera that the file will be rendered through. Make sure that the camera is not set to “persp
  • Make sure that the frame range is correct, and By Frame is set to 1. Take note of the frame range, as this will need to be typed into Smedge later on.
  • Make sure that the image resolution is set correctly. If using Arnold 5, go through each tab and make sure the settings are correct.  You will need to disable 'Auto-Convert Textures to TX Files'.  This will prevent errors with your output files.  
     
  1. If not done already, take note of the frame range of the animation. This will need to be typed into Smedge later on.
  2. Test render one frame of the animation. Make sure the frame looks appropriate, and fix any issues that arise.
  3. Save the file and close Maya.
  4. If the file is not already being kept in the Animation Server, which the render farm can access, drag the project folder onto Animation server, and fix all the filepaths inside Maya.

Using Smedge to Send a Job to the Render Farm

  1. Open Smedge on the Render Farm Computer in the Animation Studio if it is not already open. To do so, click on the "S"icon in the dock.

 

  1. If Smedge opens in Engine mode, you will need to go to System -> Connect.
  1. In the menu bar, select New Job. The New Job window will open.

 

  1. New Job Settings are as follows:
  • Type: This designates the render engine being used to complete the render. Leave this as the default Arnold for Maya, unless the file will be rendered through an alternative renderer.
  • Name: Leave this alone for now, as the name of the job will change to reflect the name of the file being rendered.
  • Priority: This should be kept at 1.
  • Paused: Keep this button unchecked, otherwise the render will not start when the job is submitted.
  • Process: Keep this as One Per Engine
  • Pool: Depending on the amount of time your render takes, choose either Slow Lane, Fast Lane, or Whole System.  If you render takes less then 10 minutes per frame, choose Fast Lane.  If your render will take more than 10 minutes per frame, choose Slow Lane.  If your render requires no priority, choose Whole System.
  • Wait For: Make sure this is set to None
  • Note: This can be kept blank.
  • Scene File: Click on the icon to the right of the text box. Find the file to be rendered in the project folder inside MayaRender Farm and select it. The job name should change automatically to reflect the Scene File.
  • Range To Process: Enter the frame range of the animation that will be rendered, with separated by a dash. Single frames to be rendered should be separated by commas.
  • Packet Size: Make sure this is set to 1.
  • Maya Project: Click on the icon to the right of the text box. Find the project folder containing the file to be rendered and select it. This may correct itself once the scene file is selected.
  • Output Folder: Click on the icon to the right of the text box. Find the images folder inside the project folder and select it.
  • Render By Frames: Leave this blank.
  • Renumber Start: Leave this blank.
  • Renumber By: Leave this blank.
  • At the top of the window, select the Advanced info tab. Make sure the overtime Kill Ratio is set to 0.0. It is important to do this even when copying an existing job. 

 

  1. Select Submit and Close to send the job to the MCAD Render Farm. The nodes listed in the bottom panel of the Smedge window will turn green to show that they are currently enabled and rendering a frame.
  2. Jobs are listed in the middle pane of the Smedge window. Select a job to view active work and completed frames. In the right pane of the Smedge window, select the History tab to view all in progress/failed/completed frames in that job. Select the Active Work tab to view what frames are currently being rendered.
  3. Once a jobs status is Completed, the frames can be dragged from the project's images folder to a portable hard drive.

If ANY issues occurs, please contact Aaron Loeks (aloeks@mcad.edu) during regular business hours (Mon-Fri 9AM-5PM) for assistance. Be advised that emails may not be replied to outside of regular business hours.

Knowledge Base Category: 

KB Footer

Can't find what you need? Let us know how we can help!